Beltronics Radar Forum  

Go Back   Beltronics Radar Forum > Custom Installed Detectors > RX75 Series

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old March 18th, 2015
bmwfreq bmwfreq is offline
Junior Member
 
Join Date: Mar 2015
Posts: 1
Default RX-75 "Rcvr ERR" message???

Has anyone experienced this error with their RX-75 remote install? "Rcvr ERR"

On the front of my RX-75 it will display "Rcvr ERR" while I'm driving around from time to time. I assumed it had something to do with the fact that I live near an Air Base now, where as before I lived here, I never experienced this issue (Ya never know what kinda stuff they could be TXing up there that could cause issues.)

Anyway, is this something that I can fix myself? Or does this error require a trip to the service center?

Thanks to all that reply!

-bmwfreq
Reply With Quote
  #2  
Old March 19th, 2015
BeltronicsPro's Avatar
BeltronicsPro BeltronicsPro is offline
Official Beltronics Rep
 
Join Date: Apr 2009
Posts: 1,015
Default

That is a Receiver Error message. There is either an issue with the receiver or with the connection to the receiver. It will need to be serviced. Do not rely on the system until the issue has been resolved.
__________________
Beltronics customer service is available from 9am-4pm Eastern Time Mon-Fri at 1-800-341-2288 or by live chat
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:13 PM.

Contact Us - Beltronics - Archive - 39 40 41 Terms of Service - 42 Top
Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2012 Beltronics
Valid XHTML 1.0 Transitional Valid CSS!